ユースケース開発Workshopコア表示ウィジェットオブジェクトビュー

注: 以下の翻訳の正確性は検証されていません。AIPを利用して英語版の原文から機械的に翻訳されたものです。

Object View

Object View ウィジェットは、Workshop モジュール内に埋め込みの Object View を表示し、単一のオブジェクトの詳細情報を提供します。Object View ウィジェットを設定するビルダーは、次のことができます。

  • 表示するオブジェクトを決定する入力オブジェクトセットを選択します。
  • フルまたはパネルの Object View を選択します。
  • 標準または設定済みの Object View を選択します。
  • Object View のヘッダーを非表示または表示にします。
  • Object View のインターフェース用に変数のマッピングを定義します。
  • フル Object View のタブの動作をカスタマイズします。

次の例は、設定済みの Object View ウィジェットで単一の Airport オブジェクトを表示したものです。

Object View ウィジェットの例

設定オプション

次に、Object View ウィジェットとその設定パネルの初期状態を示します。

空の Object View ウィジェットの設定

基本設定オプション

  • 入力データ

    • 表示するオブジェクト: 表示するオブジェクトを決定する入力変数です。フル Object View のフォームファクターでは、オブジェクトセットに複数のオブジェクトが含まれる場合、最初のオブジェクトのみが表示されます。パネル Object View のフォームファクターでは、表示の動作は設定されたパネルの動作によって異なります。
  • 表示と書式設定

    • フォームファクター: フルまたはパネルのどちらの Object View を表示するかを制御します。各フォームファクターで利用可能な追加設定については、以下のフォームファクターの設定オプションを参照してください。

    • Object View モード: 表示する閲覧の選択肢(標準または設定済み)を制御します。両者を切り替えるオプションもあります。

      Object View モード
  • 追加オプション

    • ヘッダーを非表示にする: オンにすると、Object View のヘッダーが非表示になります。

    • 空の状態: ウィジェットの入力変数が空の場合の表示を設定します。ビルダーはアイコンを選択し、表示するカスタムメッセージを設定できます。

      Object View ウィジェットのカスタムの空の状態の例

フォームファクターの設定オプション

詳細設定ドロップダウンで追加オプションを利用できます。

Object View ウィジェットの詳細設定
  • フル Object View

    • タブを非表示: Object View のタブを非表示にします。タブが1つだけの Object View ではタブが常に非表示になるため、この設定は複数のタブがある Object View にのみ適用されます。このオプションを選択すると、ユーザーは Object View の別のタブに移動できなくなります。

    • オブジェクトの切り替え時に初期タブへ移動: 表示されるオブジェクトが変わると、自動的に初期タブに戻ります。初期タブはデフォルトでは Object View の最初のタブですが、以下のパラメーターを使用して別のタブに設定できます。

    • 初期 Object View タブ ID: Object View を初めて開いたときに最初に表示されるタブを制御します。設定しない場合は、デフォルトで最初のタブが表示されます。

    • インターフェースの設定: 現在のモジュールの変数から Object View タブのモジュールインターフェースへのマッピングを定義します。まずマッピングにオブジェクトタイプを追加し、次にモジュールインターフェースが定義されているタブを選択して、インターフェースに値を設定します。詳細については、埋め込みモジュールのインターフェースの設定セクションを参照してください。レガシー Object View のタブには対応していません。

    • レガシーウィジェットに戻す: Object View ウィジェットをレガシーバージョンにダウングレードします。レガシーウィジェットはレガシー Object View のタブをより速く読み込みますが、インターフェースの設定には対応していません。

  • パネル Object View

    • パネルの動作: 入力オブジェクトセットに基づいて、パネルでオブジェクトをどのように表示するかを制御します。3つのモードを利用できます。

      • オブジェクトインスタンス: オブジェクトの件数に関係なく、入力オブジェクトセットの最初のオブジェクトを常に単一の Object View として表示します。
      • 適応型: 入力に基づいて、オブジェクトのインスタンスの表示と Object Set View を自動的に切り替えます。オブジェクトセットにオブジェクトがちょうど1個含まれる場合は、オブジェクトのインスタンスを表示します。オブジェクトセットに含まれるオブジェクトが0個または複数の場合は、Object Set View を表示します。
      • オブジェクトセット: オブジェクトの件数に関係なく、常に Object Set View を表示します。
      Object View パネルの動作
    • インターフェースの設定: 現在のモジュールの変数から Object View パネルのモジュールインターフェースへのマッピングを定義します。マッピングにオブジェクトタイプを追加し、パネルのモジュールインターフェースに値を設定して構成します。詳細については、埋め込みモジュールのインターフェースの設定セクションを参照してください。

      Object View のモジュールインターフェースのマッピング